OSPF on Cisco routers - example2 - inter-area routing(broadcast network)

ospf-2-1.png 

 

  • current example is based on example1 so please read example1 first as I will omit basic configuration and focus on this topic only
  • configure routers in Area 1 and Area0 (Router R1 will be our ABR(Autonomous border router)

 R4

(config)# interface fa0/0

(config-if)#ip address 192.168.100.2 255.255.255.0

(config-if)#no shutdown

(config)interface fa0/1

(config-if)#ip address 192.168.200.1 255.255.255.0

(config-if)#no shutdown

(config)#router ospf 4

(config-router)#router-id 4.4.4.4

(config-router)#network 192.168.100.0 0.0.0.255 area 1

(config-router)#network 192.168.200.0 0.0.0.255 area 1

(config-router)#exit

save config

 

R5

(config)# interface fa0/0

(config-if)#ip address 192.168.100.3 255.255.255.0

(config-if)#no shutdown

(config)interface fa0/1

(config-if)#ip address 192.168.201.1 255.255.255.0

(config-if)#no shutdown

(config)#router ospf 5

(config-router)#router-id 5.5.5.5

(config-router)#network 192.168.100.0 0.0.0.255 area 1

(config-router)#network 192.168.201.0 0.0.0.255 area 1

(config-router)#exit

save config

R1

(config)# interface ethernet 0/1

(config-if)#ip address 192.168.100.1 255.255.255.0

(config-if)#no shutdown

(config)#router ospf 1

(config-router)#network 192.168.100.0 0.0.0.255 area 1

(config-router)#exit

save config

  •  check ospf neighbours on routers,e.g.

#sh ip ospf neighbor

ospf-2-2.png

DR for area 0 is 3.3.3.3, for area 1 is 4.4.4.4

  •  check routing tables on few routers if routes were advertised properly,e.g. on R1,R3 and R5

#sh ip route

R1

ospf-2-3.png

 R3

ospf-2-4.png

 R5

ospf-2-5.png

O - routes learned via OSPF

O IA - routes learned via OSPF and come from different area.

based on output above our network has all routes in their routing table.

  •  check connectivity

 

ospf-2-6.png

  • check OSPF database

 R5

ospf-2-7.png 

LSA 1 - router - list of all routers(RID) in segment(area). LSA 1 is flooded only to the same area.

LSA 2 - network - one per transit,created by DR on subnet and represents subnet and router interfaces connected to subnet(DR router). LSA 2 is flooded only to the same area.THe link-state ID of LSA 2 type is ip of DR

LSA 3 - net summary - created by ABR and show us destination outside our area but in OSPF domain.

LSA 3 allows us summarization(not by default).

The link-state ID is destination network

ADV Router - router which advertise network

R1

ospf-2-8.png

R2

ospf-2-9.png

 

 

 dzbanek 2012-11-05

 

This site uses cookies. Some of the cookies we use are essential for parts of the site to operate and have already been set. You may delete and block all cookies from this site, but parts of the site will not work.